Degraded Performance

Incident Report for Capital International Bank

Resolved

The issue has been resolved.

Should you have any specific queries regarding recent Payments or FS's please contact us via Secure Messages.
Posted Nov 15, 2024 - 15:49 UTC

Monitoring

The response time for Payments and FX's processing are back at the expected levels.

We will continue to monitor the situation, should you have any specific queries please contact us via Secure Messages.
Posted Nov 14, 2024 - 13:15 UTC

Investigating

We are currently investigating an issue which is degrading the response time when submitting payment and FX's.

As we continue our investigations should you have any specific queries please contact us via Secure Messages.
Posted Nov 14, 2024 - 09:05 UTC
This incident affected: Velta (Client HUB).