The issue affecting Foreign Exchange and Payments has been resolved and the services have been reenabled.
If you have any questions concerning Payments or FX's please contact us via the secure messages functionality.
We apologise for any inconvenience this outage may have caused and will continue to monitor the situation.
Posted Apr 11, 2025 - 10:42 UTC
Investigating
We are aware that the issue affecting Foreign Exchange and Payments has reoccured. We have temporarily disabled use of these services until this issue has been resolved and are working to resolve it as a priority.
We apologise for any inconvenience this outage may be causing.
Posted Apr 11, 2025 - 10:07 UTC
Monitoring
The issue affecting Foreign Exchange and Payments has been resolved and the services have been reenabled.
If you have any questions concerning Payments or FX's please contact us via the secure messages functionality.
We apologise for any inconvenience this outage may have caused and will continue to monitor the situation.
Posted Apr 11, 2025 - 09:51 UTC
Investigating
We are aware of an issue affecting Foreign Exchange & Payments.
We have temporarily disabled use of these services until this issue has been resolved.
We are working to resolve as a priority & we will provide progress updates on this matter in due course.
Posted Apr 11, 2025 - 08:59 UTC
This incident affected: Third Party API (BW) and Velta (Client HUB).