Performance Issue

Incident Report for Capital International Bank

Resolved

This incident has been resolved.
Posted Nov 21, 2024 - 14:00 UTC

Monitoring

This issue has been resolved & is now being monitored.

Should you experience any further issues, please raise with us.
Posted Nov 19, 2024 - 13:35 UTC

Investigating

We are aware of an issue with users being unable to login to VELTA, this is being investigated as a priority.

Updates will be provided in due course, apologies for any inconvenience.
Posted Nov 19, 2024 - 13:17 UTC
This incident affected: Velta (Client HUB).