Service Degraded - Foreign Exchange Dealing and Payments

Incident Report for Capital International Bank

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 16:25 UTC

Monitoring

The previously reported issue affecting payments & foreign exchange has now been resolved.

These services have been re-enabled, however we will continue to monitor services.
Posted Mar 18, 2025 - 12:42 UTC

Investigating

We are aware of an issue affecting Foreign Exchange & Payments.

We have temporarily disabled use of these services until this issue has been resolved.

We are working to resolve as a priority & we will provide progress updates on this matter in due course.
Posted Mar 18, 2025 - 12:22 UTC
This incident affected: Third Party API (BW) and Velta (Client HUB).