Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 26, 2025 - 19:00 UTC
Scheduled
To ensure the continued reliability, security, and performance of our systems, we will be carrying out essential maintenance during the following window:
🕔 Start: Sunday, 26 October 2025 at 19:00 UTC 🕘 End: Monday, 27 October 2025 at 08:30 UTC
During this time, the system will be temporarily unavailable to all users.
This planned maintenance is part of a series of behind-the-scenes system updates to prepare for the upcoming mandatory ISO 20022 changes across the banking industry.
What this means for you: There will be no changes to how you use our systems and no disruption to your usual processing is expected. If you do experience any issues, our support team is here to help. Please contact us via the Secure Messaging feature.
We appreciate your understanding & continued support.
Posted Oct 24, 2025 - 11:11 UTC
This scheduled maintenance affected: VELTA Online Banking (Entire Site) and Mobile Application.