Potential Faster Payment Delays

Incident Report for Capital International Bank

Monitoring

Our technical team successfully implemented a fix overnight to resolve the issue causing delays in the receipt of some Faster Payments.

We will continue to monitor throughout the day to ensure everything is operating as expected.

We sincerely apologise for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Nov 19, 2025 - 09:31 UTC

Identified

Following the identification of the issue that delayed the receipt of some Faster Payments, our technical team have now resolved the root-cause and will deploy the fix overnight.

To complete this work, VELTA (Entire Site) and the Mobile App will be temporarily unavailable to all users during the following maintenance window:

🕔 Start: Tuesday, 18 November 2025 at 21:00 UTC
🕘 End: Wednesday, 19 November 2025 at 08:30 UTC

For the remainder of today, you may continue to experience delays in the timing of the receipt of Faster Payments reflecting on your account. All payments received within cut-off will be processed for value today by our Operational team.

We apologise for any inconvenience and appreciate your understanding.
Posted Nov 18, 2025 - 15:42 UTC

Investigating

The changes required to meet the new mandatory ISO 20022 payments standards were implemented this morning.

We are aware that some Faster Payments are currently being delayed and our technical teams will be deploying the technical fix overnight.

You may experience delays in the timing of the receipt of Faster Payments reflecting on your account whilst our Operational teams process these transactions for value today.

We apologise for the inconvenience and assure you that the matter has our full attention.
Posted Nov 18, 2025 - 10:26 UTC
This incident affects: VELTA Online Banking (Payments).