Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 05, 2026 - 20:00 UTC
Scheduled
To ensure the continued reliability, security, and performance of our services, we will be carrying out essential system maintenance during the following window:
🕔 Start: Friday, 5 June 2026 at 19:00 UTC (20:00 BST)
🕘 End: Friday, 5 June 2026 at 23:00 UTC (00:00 BST)
We do not expect any interruption to service during this period. However, there is a possibility of an interruption to service during the maintenance window. If this occurs, please be assured that our team will be working diligently to restore services as quickly as possible.
We apologise for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jun 04, 2026 - 16:59 UTC
This scheduled maintenance affected: VELTA Online Banking (Entire Site) and Mobile Application.