Service Degradation

Incident Report for Capital International Bank

Resolved

Incident Update: All services are now available with no reoccurrence of the incident.

Impact: Access to all bank services have been enabled.

We sincerely apologise for the inconvenience and appreciate your continued patience
Posted Nov 04, 2025 - 15:14 UTC

Monitoring

Incident Update: All services are now available, we will continue to monitor throughout the afternoom.

Impact: Access to bank services have been enabled.

We sincerely apologise for the inconvenience and appreciate your continued patience
Posted Nov 04, 2025 - 13:15 UTC

Investigating

We are currently experiencing an unexpected outage affecting the bank services. Our IT Operations team is currently working to restore functionality as quickly as possible.

Impact: Access to bank has been temporarily disabled until this issue has been resolved.

Status: An update will be provided by 14:00 or as soon as more information becomes available.

We apologise for the inconvenience and appreciate your patience.
Posted Nov 04, 2025 - 13:03 UTC
This incident affected: VELTA Online Banking (Entire Site) and Mobile Application.