Our review has identified that some payments may need reauthorisation. Please check your recent transactions to confirm they are authorised.
Posted Dec 02, 2025 - 13:54 UTC
Monitoring
All services are now available.
Access to Payments and Authorisations services have been enabled.
We sincerely apologise for the inconvenience and appreciate your continued patience
Posted Dec 02, 2025 - 12:57 UTC
Investigating
We are currently experiencing an issue impacting Velta Payment Authorisation and processing. Our IT Operations team is currently working to restore functionality as quickly as possible.
Impact: Access to VELTA Payments and Authorisations have been temporarily disabled until this issue has been resolved.
Status: An update will be provided by 13:30 or as soon as more information becomes available.
We apologise for the inconvenience and appreciate your patience.
Posted Dec 02, 2025 - 12:32 UTC
This incident affected: VELTA Online Banking (Payments, Bulk Payments, Authorisations).